Corrigindo bug do hal 0.5.11 no Arch Linux

Algum tempo depois de atualizar o pacote hal do Archlinux para a versão 0.5.11 notei que os meus pendrives não estavam mais montando automaticamente, sem nem pestanejar eu comecei a utilizar o autofs novamente enquanto precisava acessar os drivers. Porém, ontem anoite, um amigo meu que utiliza o XFCE veio me perguntando se eu já havia me deparado com tal problema, e, em seguida, já me deu a solução, eu a apliquei aqui e então estou postando para não esquecer.

Na realidade você precisará editar o arquivo:

# emacs /etc/PolicyKit/PolicyKit.conf

E adicione o seguinte conteúdo:

<config version="0.1">
  <match action="org.freedesktop.hal.storage.mount-removable">
	<return result="yes"/>
  </match>
  <match action="org.freedesktop.hal.power-management.shutdown">
	<return result="yes"/>
  </match>
  <match action="org.freedesktop.hal.power-management.reboot">
	<return result="yes"/>
  </match>
</config>

Note que as tags </config> já existirão no seu arquivo PolicyKit.conf.

Logo após, faz-se necessário reiniciar as daemons:

# /etc/rc.d/fam stop
# /etc/rc.d/hal stop
# /etc/rc.d/dbus restart
# /etc/rc.d/hal start
# /etc/rc.d/fam start

E agora tudo estará funcionando perfeitamente.

Anúncios

6 Responses to Corrigindo bug do hal 0.5.11 no Arch Linux

  1. memphyx says:

    Olá Pog… cadê o conteúdo?

    abs

  2. pognation says:

    Desculpe amigo, o código foi consumido pelo wordpress na hora de postar. Agora já arrumei. Obrigado pelo comment.

  3. AGambini says:

    Cara , tentei e não funcionou aqui não

  4. pognation says:

    Tem certeza que está correto? As tags <config> e </config> já estão incluídas no arquivo. Aqui ocorreu tudo normal. Uma saída provisória para este problema é utilizar o AutoFS, publiquei um tutorial no endereço https://pognation.wordpress.com/2008/06/04/autofs-no-archlinux/ . Até.

  5. AnderX says:

    Estava com o mesmo problema dos Pendrives e automounts pararem de funcionar após o pacman -Syu ,

    Segui a dica e agora voltou ao normal.

    PS: Não uso o FAM, então foi só dar /etc/rc.d/hal restart

    Valeu !

  6. Bruno says:

    O meu rtorrent via screen nao sai com control q. alguma dica?

Deixe um comentário

Preencha os seus dados abaixo ou clique em um ícone para log in:

Logotipo do WordPress.com

Você está comentando utilizando sua conta WordPress.com. Sair / Alterar )

Imagem do Twitter

Você está comentando utilizando sua conta Twitter. Sair / Alterar )

Foto do Facebook

Você está comentando utilizando sua conta Facebook. Sair / Alterar )

Foto do Google+

Você está comentando utilizando sua conta Google+. Sair / Alterar )

Conectando a %s

%d blogueiros gostam disto: